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Copyright, liability, and warranty

Copyright, liability, and warranty

Copyright and liability

This manual and everything described in it are copyrighted. You may not copy this manual, in
whole or part, without written consent of Panasonic Industry Europe GmbH.

Panasonic Industry Europe pursues a policy of continuous improvement of the design
and performance of its products. Therefore, we reserve the right to change the manual/
product without notice. In no event will Panasonic Industry Europe be liable for direct,
special, incidental, or consequential damage resulting from any defect in the product or its
documentation, even if advised of the possibility of such damages.

Please direct support matters and technical questions to your local Panasonic
representative.

Panasonic Industry Europe GmbH

Caroline-Herschel-Straße 100

85521 Ottobrunn, Germany

Tel: +49 89 45354-1000

Limited warranty

If physical defects caused by distribution are found, Panasonic Industry Europe will replace/
repair the product free of charge. Exceptions include:

• When physical defects are due to different usage/treatment of the product other than
described in the manual.

• When physical defects are due to defective equipment other than the distributed product.

• When physical defects are due to modifications/repairs by someone other than Panasonic
Industry Europe.

• When physical defects are due to natural disasters.
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 Warnings used in this manual

Warnings used in this manual

One or more of the following warnings may be used in this documentation:

DANGER

Indicates a hazardous situation which, if not avoided, will result in death or
serious injury.

WARNING

Indicates a hazardous situation which, if not avoided, could result in serious or
moderate injury.

CAUTION

Indicates a hazardous situation which, if not avoided, could result in minor or
moderate injury.

NOTICE

Indicates a property damage message.
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Copyright and liability

This manual and everything described in it are copyrighted. You may not copy this manual, in
whole or part, without written consent of Panasonic Industry Europe GmbH.

Panasonic Industry Europe pursues a policy of continuous improvement of the design
and performance of its products. Therefore, we reserve the right to change the manual/
product without notice. In no event will Panasonic Industry Europe be liable for direct,
special, incidental, or consequential damage resulting from any defect in the product or its
documentation, even if advised of the possibility of such damages.

Please direct support matters and technical questions to your local Panasonic
representative.

Panasonic Industry Europe GmbH

Caroline-Herschel-Straße 100

85521 Ottobrunn, Germany

Tel: +49 89 45354-1000

Limited warranty

If physical defects caused by distribution are found, Panasonic Industry Europe will replace/
repair the product free of charge. Exceptions include:

• When physical defects are due to different usage/treatment of the product other than
described in the manual.

• When physical defects are due to defective equipment other than the distributed product.

• When physical defects are due to modifications/repairs by someone other than Panasonic
Industry Europe.

• When physical defects are due to natural disasters.
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Warnings used in this manual

One or more of the following warnings may be used in this documentation:

DANGER

Indicates a hazardous situation which, if not avoided, will result in death or
serious injury.

WARNING

Indicates a hazardous situation which, if not avoided, could result in serious or
moderate injury.

CAUTION

Indicates a hazardous situation which, if not avoided, could result in minor or
moderate injury.

NOTICE

Indicates a property damage message.
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 1 Overview

1 Overview

1.1 Introduction to the Panasonic FP OPC Server

The Panasonic FP OPC Server is a 32-bit Windows application with a modern user interface.
It realizes the server end in the standard client/server model and incorporates the OPC DA
standard. It allows you to share information between our proprietary devices (Panasonic FP
Series PLCs) and any other device or application that supports the OPC DA standard.

OPC DA technology succeeds Microsoft's Dynamic Data Exchange (DDE) technology in the
demanding industrial environment.

1.2 OPC and its underlying technology

OPC (OLE (Object Linking and Embedding) for Process Control) is the successor of DDE
technology.

According to the OPC Foundation, “OPC is open connectivity in industrial automation and
the enterprise systems that support industry. Interoperability is assured through the creation
and maintenance of open standards specifications. There are currently seven standards
specifications completed or in development (“What is OPC?”; www.opcfoundation.org)”.

OPC is based on a series of approved standards and technologies of the consumer
computer world. It was originally based on OLE COM (Component Object Model) and DCOM
(Distributed Component Object Model), which provide the framework. Microsoft even added
OPC standard to the OLE specification. OPC interface applications are built once and used
several times, thus are approved and under constant quality control.

With OPC, data can be exchanged efficiently using a standardized interface, hence vendors
do not have to implement their own communication drivers. Therefore it allows vendors to
reduce implementation costs and save time, thus reducing the project cycle time.

1.2.1 OPC Foundation

The OPC Foundation defines itself as being "dedicated to ensuring interoperability
in automation by creating and maintaining open specifications that standardize the
communication of acquired process data, alarm and event records, historical data, and
batch data to multi-vendor enterprise systems and between production devices. Production
devices include sensors, instruments, PLCs, RTUs, DCSs, HMIs, historians, trending
subsystems, alarm subsystems, and more as used in the process industry, manufacturing,
and in acquiring and transporting oil, gas, and minerals (OPC Foundation; “What is the OPC
Foundation?”; www.opcfoundation.org)”.
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1 Overview

The OPC Foundation is a cooperation of automation control product vendors and Microsoft.
As of 2006, the foundation had about 300 members worldwide. The main standard, with
which it all began, is the OPC DA (Data Access) specification.

Compliance tests are provided to the members to test OPC conformity.

1.2.2 COM

The COM (Component Object Model) interface defines the externally visible binary structure
of a COM object. The COM object is hereby the implementation of this model and can be
based on several interfaces which define access to the object. It offers runtime access to
the incorporated interfaces of a COM object and interprocess communication. Reference
counting is implemented to manage the object's life cycle. Interactions between components
are based on method-accesses defined in interfaces. COM applications are restricted to run
locally on single computers only.

1.2.3 DCOM

Upon inception, DCOM (Distributed Component Object Model) faced two major challenges:

• program-based processing of information, which led to information being represented
differently

• backwards compatibility to existing COM and DDE applications

OLE is based directly on DCOM. The DCOM interface allows COM applications to be
distributed on several computers, providing a single security concept.

DCOM applications are restricted by not:

• running over firewalls

• being platform independent (only Microsoft operating systems are supported)

1.2.4 OPC Data Access (DA)

Version 1 of the OPC DA (Data Access) standard was released in 1996. Today version 3.0
is available. A task force within the OPC Foundation maintains and revises the OPC DA
specification.

The specification shows and describes how to construct client and server applications
and allows vendors to quickly develop their own applications. It defines object hierarchy
consisting of several OPC server objects, which in turn can consist of several OPC group
objects. The group objects themselves can be composed of OPC item objects. OPC items
correspond to process values and represent connections to data sources.

12 ACGM0143V7EN
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 1 Overview

The COM interface incorporated in the server offers the client two object types: group
and item. A server object is automatically created after the client connects to the server.
Associated with each item is a time stamp, its quality and the value of the item as a
VARIANT type. The item tags--tag, node or property objects--have to be realized on the
server side.

The node objects can contain either other node objects or leaf objects. Node objects are
implemented as channel, device or tag group elements within the FP OPC Server. Tag
objects, which are implemented as tag elements, represent the leaf objects in the object tree.

The OPC client connected to the OPC server is responsible for the type of information
it retrieves. It has to define the group structure, the poll rate and the read type, i.e.
asynchronous or synchronous data retrieval. Using synchronous data retrieval, the client has
to wait until the read operation is finished; using asynchronous data retrieval, on the other
hand, allows the client to be informed immediately when data changes.

1.3 Features of the FP OPC Server

The Panasonic FP OPC Server is a OutProc Server, thus the server application is started
from an autarkic executable file. The server allows high-performance data transfer between
applications that support the OPC DA standard and Panasonic FP Series PLCs.

The following features are provided:
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1 Overview

1.3.1 Connectivity

The server provides “two-sided” connectivity: one side provides access to applications that
support OPC DA; the other side provides access to FP Series PLCs.

In order to enable the user to perform functional tests, a simulation mode is implemented.
This mode allows you to design the application without any PLC being connected to the
computer.

OPC connectivity

The server complies to the following OPC DA client/server technologies:

• OPC DA 1.0a

• OPC DA 2.05a

• OPC DA 3.0

Data can be exchanged between client and server in asynchronous, synchronous and
refresh mode.

Device connectivity

A standardized interface allows you to:

• Monitor data from Panasonic FP PLCs

• Synchronize data access and data writing

• Use various communication types

PLCs can be accessed via serial port and Ethernet. The server offers modem support to
connect to remote stations via dial-up phone calls.

Specify the communication mode at the communication channel level when you configure
the application. Setting up the communication channel to use the modem means that dialing
and connecting to the remote device is fully transparent to the OPC client application.
Modem connections and direct serial communication work similarly.

1.3.2 Interruption tolerance

In case a connected device stops responding, for instance because of a line interruption,
the optimized communication is carried on for the still connected devices. Thus, the
communication breakdown does not influence the time-out or response behavior of the
devices which are still online. If the device starts being responsive again, the data transfer
from / to the previously disconnected PLC is reinitialized and carried out normally.
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1.3.3 Communication driver test and protocol adaptation

If the server or application created with the server should be tested, the user can use a
simulation driver to simulate reading and writing from and to virtual devices.

To test MEWTOCOL protocol communication, the channel settings made by the user
can be tested directly in the server application. Furthermore, the user can influence the
type of protocol (use of RD commands instead of MD commands) to be used to prevent
interdependencies with other applications using the MEWTOCOL protocol, for instance.

For detailed information, please refer to the Options dialog of the Tools menu in the online
help.

1.3.4 User interface

A modern, intuitive user interface allows you to configure the server. While creating the
application, sophisticated user assistance is available at any time. Various hints and error
notifications help you configure the server. Online documentation is omnipresent to clarify
the server configuration application. You are warned of possible faulty settings or changes
while the server is running. Wizard dialogs assist you in creating and altering elements.

The server allows you to change the display of the main window. The server can appear
minimized as an icon in the system tray or maximized on the desktop. If started by an OPC
client, the server is automatically started minimized in the tray icon, but can be brought to the
foreground by simply double clicking the icon in the system tray.

1.3.5 Namespaces

The OPC client browsable namespace provided by the server represents a description of all
process values an OPC client can query from. It can be distinguished between three different
types of namespace elements.

For detailed information, please refer to Namespaces.

Static, Manual Namespace

The manual, "static" namespace is specified in the configuration user interface of the server.
The user who administrates the server, creates channels, devices, tag groups and tags. The
user specifies the settings of the communication lines, the PLC and the data sources to be
provided to the client.

For detailed information, please refer to Static, Manually Defined Namespace.
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System Status Namespace

This namespace contains system tags, which are used to provide status feedback on the
server running. The client simply creates items of these tags and thereby retrieves the server
status directly in the client application. The system status namespace shows the system
date, system time, uptime, project path, number of tags, number of tags active in the clients
and the number of clients connected.

For detailed information, please refer to System Status Namespace.

MEWTOCOL OPC Server Compatibility Namespace

A MEWTOCOL OPC Server (the predecessor of this server) compatibility namespace is
also provided. The user configures the communication settings, which are common for the
communication lines (serial or Ethernet). To use this namespace, the OPC client has to
create the items such that they follow a certain syntax. The item path can be adapted to the
specific needs.

For syntax regulations and restrictions, please refer to MEWTOCOL OPC Server
compatibility namespace.

1.3.6 Basic version

The FP OPC Server is also available in a basic version, which can be installed without a
license number. After using the basic version for 120 minutes, you will be asked to save your
project and all connections to the server are terminated. Watch the title bar to see how many
minutes are left.

You must confirm the message box displayed before you can restart the server.
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 1 Overview

This message box is also displayed if the connection is closed before the time has expired.

Please contact your local Panasonic distributor for the unlimited version.

1.3.7 Online changes

During online sessions, i.e. when OPC clients are connected to the FP OPC Server, you can
make comprehensive changes to the currently opened project. You can add new elements
such as channels, devices, tag groups or tag elements to the project. You can apply all kinds
of changes, except deleting and renaming, to all elements.

Note

You can only delete and rename elements which are not currently being used by the client.

1.4 Hardware and software requirements

Item Required

Hard disk space 20MB or more

Lowest capacity memory 128MB or more

Hardware

Available display resolution 1024 x 768 or more

Operating Systems Windows® 10, Windows® 11
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2 First steps using the FP OPC Server

2 First steps using the FP OPC Server

2.1 Install the FP OPC Server

Before you begin the installation, unzip “SetupFPOPCServerxx.zip” and save it on your hard
drive.

1. Double-click “SetupFPOPCServerxx.exe” to run the installer

2. Select [Next]

3. Read and accept the "License Agreement"

4. Select [Next]
Enter your customer information and serial number (for the unlimited version only).
The Basic version (see Basic Software in the online help) runs without serial number.

5. Select [Next]
The following dialog appears and allows you to review the path you entered.

6. Select [Browse] to select the installation directory

7. Select [Next]
The following dialog appears.
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 2 First steps using the FP OPC Server

8. Specify the location of the program icons in the start menu

9. Select [Next]
The dialog "Start Copying Files" appears so you can review your settings.

10. If the settings are OK, select [Next] to install the software

11. Select whether to restart your PC and then [Finish] to finish the installation
The Panasonic FP OPC Server is now installed on your system.

Note

Start the FP OPC Server at least once to register the application in the windows system.

2.2 Start/Stop the FP OPC Server application

2.2.1 Start the FP OPC Server application

The OPC server can start in two modes:

• manually

• automatically, when an OPC client application tries to connect to the server.

Manual start

1. Double-click the FP OPC Server icon 
The configuration user interface with an empty project is started.

Automatic start

2. Start the OPC client application
The Softing Demo Client is started.

3. Browse the available server list, select FP OPC Server and connect to the by double-
clicking hte icon

Now the OPC server is started automatically and the server icon is displayed in the
system tray.
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2 First steps using the FP OPC Server

The default project file (specified under “Tools” > “Options...”) is automatically loaded, the
OPC subsystem is started and the client is connected to the server. If no default project has
been specified, the most recently used project is loaded.

Note

If the OPC server application is started manually but the OPC subsystem has not been
started, a new client connect starts the OPC subsystem and connects to this server instance.

Related topics

First steps using the FP OPC Server (page 18)

Options (page 45)

System tray (page 73)

2.2.2 Stop the FP OPC Server application

The OPC server application can be stopped in two ways:

• manually, e.g. by user intervention

• automatically: The OPC server automatically stops when all clients have disconnected
and when the configuration window is minimized to the system tray.

Manual stop

1. Stop the FP OPC Server application manually
• Select “File” > “Exit” or tray icon menu

• Select the close button of the application window

Related topics

2.3 Channels

A channel represents a means of communication. The following means of communication
are possible:

• Serial communication (RS232)

• Ethernet
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 2 First steps using the FP OPC Server

• USB

Please also refer to:

• Channel element in the online help

• New Channel Wizard

2.3.1 Add a New Channel

There are four ways to add a new channel element:

1. Double-click the dummy element

2. Click a toolbar icon

3. “Edit” > “New” > “Channel”
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2 First steps using the FP OPC Server

4. Select “New Channel” from the navigator pane's pop-up menu.

In all cases the wizard starts. Now create the new channel.

5. Specify a name for the new channel

6. Select the driver

7. Fill in the communication settings in the “Communication settings” dialog by clicking
“Settings...”

Related topics

Dummy Elements of Navigator Pane (page 52)

New of File Menu (page 37)

Navigator Pane (page 51)

New Channel Wizard (page 61)

Driver Selection (page 62)

“Communication settings” dialog (page 68)

22 ACGM0143V7EN



 2 First steps using the FP OPC Server

2.3.2 Update an Existing Channel

To update and existing channel element:

• double-click the channel element, or

• select Properties from the toolbar or pop-up menu.

Select "Properties" from the toolbar.

Select "Properties" from the pop-up menu.

2.4 Element Structure

The FP OPC Server allows the creation of a clearly membered hierarchical element structure
that fits the nature of the application. The hierarchy consists of several layers: On the first
layer, multiple communication channels specify the mean communication. The channels
comprise multiple devices to specify the PLC and its station number. Devices can contain
multiple tag groups to segregate tag data on a group-by-group basis. Devices or tag groups
themselves contain the tag data.

A state-of-the-art import/export mechanism allow you to save, exchange or edit the data
in the XML file format. Exchanging data can also be done using a CSV file. For further
information, please refer to Import/Export Tag Information.
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2 First steps using the FP OPC Server

2.5 Devices

A device represents a hardware device, a Panasonic FP series PLC, connected to the OPC
server.

The data sources provided by the server application in the namespaces are situated on
these devices. Data sources are hereby flag or register addresses, which can be accessed
by the OPC server.

Please also refer to:

• Device element in the online help

• New Device Wizard

2.5.1 Add a New Device

1. Open the wizard to create a new device element in one of the four ways described in
"Add a New Channel"
Here the dummy item is used to create a new device.

The wizard opens.

2. Specify a name for the new device.

3. To test the communication settings specified for the "Channel", select [Test
Communication]
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 2 First steps using the FP OPC Server

To update an existing device, please refer to the procedure of update an existing channel.

2.5.2 Update an Existing Device

Update the element as described in "Update an Existing Channel".

2.6 Tag Groups

A tag group  represents a structural element for grouping tag elements according to your
application's needs. For instance, a group "Temperature" and "Liquid Level" can be created
in the same device to distinguish between data sources related to temperature and those
related to liquid levels.

Additionally a tag group can be used to assign a certain time stamp to all tags included in
the tag group. The time stamp can be specified by a DATE_AND_TIME variable in the PLC
project.

Please also refer to: New tag group wizard

2.6.1 Add a New Tag Group

1. Open the wizard to create a new tag group element in one of the four ways described in
"Add a New Channel"
Here the pop-up menu is used to create the new tag group.

The wizard opens.
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2. Specify the name of the tag group element

To update an existing tag group, please refer to the procedure of update an existing channel.

2.6.2 Update an Existing Tag Group

Update the element as described in "Update an Existing Channel".

2.7 Tags

A tag represents a single PLC variable (address).

Please also refer to:

• Tag pane

• New Tag Wizard

2.7.1 Add a New Tag

1. Create a tag as described in "Add a New Channel" section
Here, the dummy item is used to create the new tag.

2. Double-click to add a new tag

The wizard opens.
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3. Specify the name, correct address, data type, description and the access type of the tag
element

4. Select [Insert] to add the element directly to the list without closing the dialog
Repeat selecting [Insert] to create a series of tag elements that count up tag names and
addresses.

5.
Select  when you have finished adding all elements

An example namespace.

2.7.2 Update an Existing Tag

You can update an existing tag in several ways.

For example, simply click in the field which should be changed, e.g. to update a name.

Change multiple elements by selecting the desired elements and typing or selecting the new
value. In this case, 3 elements were selected and their access rights changed to "read only".
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You can also change the tag's properties by double-clicking the tag to activate the wizard.

Note

You can only update values for individual elements when you use the wizard.

2.8 Server Operation

In order to accept connections for an OPC client application, you must start the server's OPC

subsystem by clicking . After the server is started, clients can connect to the server.

Note

If the OPC server application is started manually but the OPC subsystem has not been
started, a new client connect starts the OPC subsystem and connects to this server instance.
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2.8.1 Start the Server

You will be notified when the server has been started successfully by:

• a log message in the system log pane and

• an incrementing "Up Time" value in the server status pane.

You can also see that a client is connected (here the Softing Demo Client) in the system log
and server status panes.
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2.8.2 Stop the Server

To stop the OPC subsystem, press .

Note

All connections to OPC clients are terminated.

Now the demo client has been disconnected. A log message informs you that the OPC client
has been disconnected and that the server has stopped.

2.9 Transferring Project Information

You can save project data in XML or CSV format and exchange tag data between various
OPC servers, e.g. Kepware or Beijers. You can also import global variables from Control
FPWIN Pro in CSV format.

2.9.1 Open/Save Project

Open Project

1. Select “File” > “Open” or  from the toolbar
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In the file open dialog all supported file formats (*.pos, *.xml) are displayed.

2. Select the desired file and click [Open]
Alternatively, select a file from the recently opened file list.

Note

If no default project is specified in the options dialog, the most recently used project is
automatically loaded when the client application starts the OPC server.

Save Project

3. Select “File” > “Save” or “Save As…” or  of the toolbar

The file save dialog opens:

4. Specify the project file name and file type (binary (*.pos) or XML (*.xml) format)

5. Select [Save]

Related topics

Options (page 45)

Save (page 38)

Save As (page 38)

2.9.2 Import/Export Tag Data

In order to exchange, import, export or edit tag data, an export/import mechanism is
available.
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Import tag data

1. Select the device or tag group element for which you want to import data

2. Select “Import” from the pop-up menu, the File menu or the navigator's toolbar

3. In the “File Open” dialog, select the XML or CSV file you want to import
According to the import settings under “Tools” > “Options”, you can select whether:
• tags available in the import file but not in the project are added to the project

• tags not available in the import file but in the project are deleted from the project:

Tags available in the import file and in the project will be updated.
The data is imported into the selected device or tag group item.
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Import other file formats
The OPC Server can import global variables exported from FPWIN Pro or tag data
exported from OPC Servers (Panasonic FP OPC Server, Kepware OPC Server, Beijers
OPC Server). The various file formats are displayed below.
• FPWIN Pro

• Kepware OPC Server

• Beijer OPC Server

Export tag data

4. Select the device or tag group element you want to export
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5. Select “Export” from the pop-up menu, the File menu or the navigator's toolbar

6. Specify the file name and type

7. Select where you wish to save the file

8. Select “[Save]”

Now you can edit the file if desired, e.g. with a text editor:

Example for tag data exported in XML format

Example for tag data exported in CSV format
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Related topics

Device Element (page 52)

Tag Group Element (page 52)

Options (page 45)
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3 Graphical User Interface (GUI)

3.1 Configure the Working Area

The FP OPC Server configuration user interface consists of various panes. All panes offer a
pop-up menu and you can access most functions related to the panes with toolbar icons. For
each item in the panes, context sensitive help can be displayed in the help pane. Tool tips
assist the user in understanding the topics when the cursor passes over them. You can dock
all panes except the tag pane (2). You can close unneeded panes to enlarge the working
area. Use the view menu to display the panes after they have been closed.

You can resize and move the entire application anywhere on the desktop. All user-defined
layout settings, pane status and window position are saved upon closing and restored when
the server is restarted.

(1) The navigator pane shows the hierarchical structure of channel, device and tag group
elements. Elements of these types can be created and changed in this pane.

(2) The tag pane is where tag elements are created or updated.

(3) The system log pane shows the latest log messages, such as server status messages, client
connections or connection timeouts and informs the user about these events.

(4) The server status pane shows the server status information.

The help pane displays the online help. You can temporarily slide open the pane by moving
the mouse over the icon. Click on the icon if you prefer the pane to stay visible.
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Customize your working area

You can move or dock all panes except the tag pane anywhere in the window.

3.2 Menu Names and Commands

The menu bar contains 6 menu names shown above. Please refer to the online help for
detailed information under the keyword of the respective menu name.

3.2.1 File Menu

The File menu offers access to all file and project operations.

3.2.1.1 New of File Menu

1. Select “File” > “New” to create a new, empty project.
The user is prompted if the actual project has not been saved.
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3.2.1.2 Open

1. Select “File” > “Open...” to open a project file.
Supported formats are XML project files (*.xml) and the binary file format (*.pos).

Related topics

Load/Save The Project (page 68)

3.2.1.3 Save

1. Select “File” > “Save” to save the current project as a binary (*.pos) or XML file (*.xml).

Related topics

Load/Save The Project (page 68)

3.2.1.4 Save As

1. Select “File” > “Save As” to save the current project data as a file with a different name
and/or location in binary (*.pos) or XML (*.xml) format.

Related topics

Load/Save The Project (page 68)

3.2.1.5 Import

Select the "Import" command to import stored tag data into the currently selected device
or tag group (for detailed information, please refer to navigator pane). Two import file
formats are supported: XML and CSV. The file type is hereby selected in the FileOpen dialog
presented after selcting the "Import" command.

• Import from CSV
Select the CSV file type to import tag data from a CSV file (Character Separated Values).
The file contains global variables exported from FPWIN Pro or tag data exported from
OPC Servers (Panasonic FP OPC Server, Kepware OPC Server, Beijers OPC Server).
For detailed information, please refer to Accessing/Storing Project Information.

• Import from XML
Select the XML file type to import tag data from a previously exported XML file.
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For detailed information, please refer to Accessing/Storing Project Information.

3.2.1.6 Export

Select the "Export" command to export tag data from the currently selected element (device
or tag group). The two export file formats are supported: XML and CSV.

• Export to CSV
Select the CSV file type to export tag data to a CSV file (Character Separated Values).
The data can be easily changed for example using a simple text editor.
For detailed information, please refer to Accessing/Storing Project Information.

• Export to XML
Select "Export to XML" to export tag data to a XML file. The data can be easily altered for
example using a simple text editor.
For detailed information, please refer to Accessing/Storing Project Information.

3.2.1.7 Recent File List

The recent file list contains the last 16 project files loaded or saved. Open the files by clicking
on the file name. If the files have been moved or deleted from the hard drive, their names will
disappear in the file list.

Note

Only project files are listed, not export/import files.

3.2.1.8 Exit

1. Select “File” > “Exit” to close the application.

3.2.2 Edit menu

The Edit menu allows you to create new channels, devices, groups and tags as well as
execute the standard Windows editing commands: cut, copy, paste, delete and select all.
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3.2.2.1 New of Edit Menu

Under "New", select submenu commands to create new elements.

For detailed information, please refer to:

• Add a New Channel

• Add a New Device

• Add a New Tag Group

• Add a New Tag

New Channel

1. Select “Edit” > “New” > “New Channel” to create a new channel element in the navigator
pane.
With this command a wizard appears and offers easy creation of the new element.

Related topics

Channel Element (page 51)

Navigator Pane (page 51)

New Channel Wizard (page 61)

New Device

1. Select “Edit” > “New” > “New Device” to create a new device element in the navigator
pane.
With this command a wizard appears and offers easy creation of the new element.
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Related topics

Device Element (page 52)

Navigator Pane (page 51)

New Device Wizard (page 63)

New Tag Group

1. Select “Edit” > “New” > “New Tag Group” to create a new tag group element in the
navigator pane.
With this command a wizard appears and offers easy creation of the new element.

Related topics

Tag Group Element (page 52)

Navigator Pane (page 51)

New Tag Group Wizard (page 64)

New Tag

1. Select “Edit” > “New” > “New Tag” to create a new tag element in the tag pane.
With this command a wizard appears and offers easy creation of the new element.

Related topics

New Tag Wizard (page 66)

3.2.2.2 Cut

1. Select “Edit” > “Cut” to cut out the selected elements.
You can then paste the element into another channel, device or tag group, for instance.

Related topics

Channel Element (page 51)

Device Element (page 52)

Tag Group Element (page 52)
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3.2.2.3 Copy

1. Select “Edit” > “Copy” to copy the currently selected elements.
You can paste the element into another or even the same channel, device or tag group,
for instance. If you paste the element into the same parent element, the element name
is adapted and the element is added as a new element.

Related topics

Channel Element (page 51)

Device Element (page 52)

Tag Group Element (page 52)

3.2.2.4 Paste

1. Select “Edit” > “Paste” to paste the elements from the clipboard into another or the same
channel, device or tag group, for instance.

Related topics

Channel Element (page 51)

Device Element (page 52)

Tag Group Element (page 52)

3.2.2.5 Delete

1. Select “Edit” > “Delete” to erase the currently selected elements from the tree (within the
navigator pane), or from the list (within the tag pane).

Note

If the items selected for deletion contain subitems, they will be deleted as well.

Related topics

Navigator Pane (page 51)

Tag Pane (page 53)
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3.2.2.6 Select All

1. Select “Edit” > “Select All” to select all tag elements in the list (within the tag pane.

Related topics

Tag Pane (page 53)

3.2.3 View Menu

Display the navigator, system log and server status panes via this menu if they are hidden.

Note

Display the help pane via the help menu.

Further information:

• Configure the working area

3.2.4 Server Menu

The Server menu contains commands to control the server and set global communication
parameters.
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3.2.4.1 Start Server

1. Select “Server” > “Start” to start the server.
The command invokes the specified namespace to be loaded. After the server has
been started successfully, it accepts incoming OPC client connections. For an detailed
description, please also refer to start the server (First Steps).

Note

• The “Start” command is only available if the server is not already running.

• The server is started automatically if the client invokes a connection to the OPC
server.

Related topics

Namespaces (page 74)

Start the Server (page 29)

3.2.4.2 Stop Server

1. Select “Server” > “Stop” to stop the server.
The command invokes the namespace to be unloaded. After the server has been
successfully stopped, no incoming OPC client connections are accepted. For an
detailed description, please also refer to stop the server (First Steps).

Note

• All connected clients will be disconnected.

• The “Stop” command is only available if the server is not already stopped.

• If the FP OPC server is stopped and the client invokes a new connection, another
instance of the OPC server is started.

Related topics

Namespaces (page 74)

Stop the Server (page 30)
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3.2.4.3 Communication settings

1. Select “Server” > “Communication Settings” to open the “Communication settings”
dialog.
Use these settings to configure the MEWTOCOL OPC Server compatibility namespace.
The following network types are available:
• Serial communication

• Ethernet (Local) communication

• USB communication

Related topics

MEWTOCOL OPC server compatibility namespace (page 76)

Serial Communication Settings (page 69)

Ethernet (local) communication settings (page 71)

USB (GT) communication settings (page 73)

3.2.5 Tools Menu

The Tools menu offers commands to start configuration and option dialogs.

3.2.5.1 DCOM Configuration of Tools Menu

1. Select “Tools” > “DCOM Configuration” to start the external Windows DCOM
configuration dialog.

Related topics

DCOM configuration (page 87)

3.2.5.2 Options

Select “Tools” > “Options” to configure the server application.
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The options dialog (here every option is expanded) is divided into two areas: The
configuration area and the description area at the bottom of the view. By selecting an item in
the configuration area, the corresponding help information is displayed in the help area.

General Settings

Setting Description Default setting

Default Project Specify the path to the default project which should
be loaded if the server is automatically started by the
client.
If left empty, the last recently used project is loaded.

Empty

Save formatted XML Turn this option on if the XML project file should be
formatted to be able to read it properly.
Turning on this option may lead to an increased time
to save the project and a bigger project file size.

False

Minimum server poll
rate (ms)

Specify the minimum poll rate the client application
can request. If for instance all the PLCs are
connected using Modem communication, increase
this value to meet the current communication timings.
Also if debug message logging is turned on, this
value should be increased.
Note: If this value is changed, the server has to be
stopped and restarted to make the changes effective.

100

• Verbose Level Settings
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Setting Description Default setting

Ask before an
element is deleted

If set to true, the user gets prompted if the
element should be deleted. Turning on this
option may prevent false deleting of elements.

True

Ask before a client is
disconnected

If set to true, the user gets prompted if his
current changes lead to a disconnection of the
connected clients.

True

• Import Settings

Setting Description Default setting

Add new tags from
the import file

If set to true, all tags that are available in the
import file but not in the project configuration are
added.

True

Delete tags not
available in the import
file

If set to true, all tags that are available in the
project configuration but not in the import file are
deleted.

True

Event Log Settings

Setting Description Default setting

Enable event message
logging

If set to true, event logging into a file is enabled
and the subsettings of this item are enabled.

True

Log file path Specify the path to the file where the logging
information should be written to.

C:\Documents
and Settings
\ <username>
\ Applications
\ Panasonic
MEW Control \
FPOPCServer
\ FPOPC
ServerLog.txt

Maximum number of
events to log (lines)

Specify the maximum number of lines to be stored
in the log file.

1000

Message level • Specify the kind of log messages to be stored
in the log file and printed in the log pane.

• Select “Level 0 (show Error messages)” if only
error messages should be enabled.

• Select “Level 1 (show Error & Warning
messages)” if error and warning messages
should be enabled and

• “Level 2 (show Error & Warning & Information
messages)” to enable error, warning and
information messages.

Level 2 (show
Error & Warning
& Information
messages)

Enable OPC subsystem
message logging

If set to true, messages of the OPC subsystem are
written to the log file with the prefix 'OPC_'.
Enabling this option may have negative effects on
the performance. Also think about increasing the
"Minimum server poll rate".

False
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• Enable debug message logging

Setting Description Default setting

If set to true, additional debug messages are
written to the log file.
Enabling this option may have negative effects
on the performance. Also think about increasing
the "Minimum server poll rate".
Note: If this value is changed, the server has to
be stopped and restarted to make the changes
effective.

False

Timing and filling change
threshold percentage (%)

Specifies the threshold value in percent.
Any change to the current timing (e.g. Driver
response time) or internal hash tables that
exceed this threshold is written to the log file. By
setting this value to '0' all debug messages are
written to the log file.

10

Force timing and filling
change logging every
(min)

If set to any value greater than 0, timing or filling
changes are written to the log file at the interval
specified.

5

Enable debug message
logging to CSV files.

If set to true, additional I/O debug messages
are created for each thread and are written to
specific CSV files. The files can be found in the
path specified with the log file path option.

False

• Enable memory status message logging

Setting Description Default setting

If set to true, additional memory status messages
are written to the log file.
Note: If this value is changed, the server has to
be stopped and restarted to make the changes
effective.

False

Memory change relative
threshold (%)

Specifies the threshold value in percent. Any
change to the current memory status message
that exceeds this threshold is written to the log
file.
Note: Either percentage or absolute threshold
can be set!

10

Memory change absolute
threshold (kb)

Specifies the absolute threshold value in
kilobytes. Any change to the current memory
status message that exceeds this threshold is
written to the log file.
Note: Either absolute or percentage threshold
can be set!

0

Force memory status
message logging every
(min)

If set to any value greater than 0, a memory
status message is written to the log file at the
interval specified.

5
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Client Interaction Settings

Setting Description Default setting

Enable static namespace Enable the static namespace to allow the OPC
client to browse the manually defined namespace.

True

Enable system status
namespace

Enable the system status namespace to allow
the OPC client to browse the system status
namespace.

True

Enable MEWTOCOL
compatibility namespace

Enable the MEWTOCOL compatibility namespace
to allow the OPC client to create the compatibility
namespace of the previous MEWTOCOL OPC
Server.

False

Client shutdown timeout
(s)

Set the timeout after which it can be assumed that
the OPC client has received the termination signal
and has disconnected from the server.

10s

Ignore "real" server
response time in client
update

If set to true, quality status of the item shown in
the OPC client is not toggling between "Good" and
"Bad" if the response time of the server is greater
than the OPC client's poll rate.
Note: If this value is changed, the OPC subsystem
has to be stopped and then started again to make
the changes affective.

True

I/O Settings

Setting Description Default setting

Enable MEWTOCOL
monitor commands

Disable this option if a second application, besides
the FP OPC Server, also uses MEWTOCOL
monitor commands to retrieve data from the PLC.
Disabling this function may lead to a decreased I/O
performance of the server.

True

Related topics

Import/Export Tag Data (page 31)

Import/Export Tag Data (page 31)

System Log Pane (page 56)

Static, Manually Defined Namespace (page 74)

System Status Namespace (page 75)

MEWTOCOL OPC server compatibility namespace (page 76)
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3.2.6 Help Menu

The help menu contains commands to access the online documentation, which can
displayed inside the application or as an external help window.

See also help pane.

3.2.6.1 Contents

1. Select “Help” > “Contents” to open the online documentation in an external help window
with the "Contents" tab displayed.

3.2.6.2 Search for Help on

1. Select “Help” > “Search for Help on” to open the online documentation in an external
help window with the "Search" tab displayed.

3.2.6.3 What's This?

1. Select “Help” > “What's This?” to get help on the topic or item selected with the help

cursor .

3.2.6.4 Dynamic Help

1. Select “Help” > “Dynamic Help” to open or show the help pane:

3.2.6.5 About FP OPC Server

1. Select “Help” > “About FP OPC Server…” to get the version information.
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3.3 Panes

The FP OPC Server user interface contains 5 panes described as follows.

3.3.1 Navigator Pane

The navigator pane shows channel, device and tag group elements in a hierarchical
structure. A wizard starts at each level to help you create new elements. To update existing
elements, simply double-click the item; a wizard will appear in this case, too. You can directly
access all commands available in this pane via the toolbar or pop-up menu.

Drag&Drop allows you to conveniently move device elements and tag group elements.

Note

On each hierarchical level, the name of the element has to be unique! For instance, only one
channel element can be named "Com1".

For a detailed description of the navigator pane, please refer to the online help under the
keyword "Navigator pane".

3.3.1.1 Elements

You can insert channel, device, tag group or dummy elements into the navigator.

Channel Element

A channel element  represents the communication channel via which data is retrieved

from or written to the connected device. In this element, the driver used (simulation or
MEWTOCOL) and the communication settings are stored. For further information, please
refer to wizard (new channel mode) and channel operations.
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Device Element

A device element  represents a device communicating via its parent's communication line.
The element contains information about each device's station number connected via the
same channel. For further information, please refer to wizard (new device mode) and device
operations.

Tag Group Element

A tag group  represents a structural element for grouping tag elements according to your
application's needs. For instance, a group "Temperature" and "Liquid Level" can be created
in the same device to distinguish between data sources related to temperature and those
related to liquid levels.

Additionally a tag group can be used to assign a certain time stamp to all tags included in
the tag group. The time stamp can be specified by a DATE_AND_TIME variable in the PLC
project.

For further information, please refer to the new tag group wizard and add a new tag group.

Dummy Elements of Navigator Pane

To simplify creating new elements, two kinds of dummy elements exist:

1.

The dummy channel element is available if the element tree is empty. It is used to create
a new channel element by simply double-clicking the item. The wizard that opens helps
you create a new element.

2.

The dummy device element is available whenever the element has no siblings. It is used
to create a new device element by simply double-clicking the item. The wizard dialog
that opens helps you create a new element.

3.3.1.2 Navigator Pane's Pop-Up Menu

Using the pop-up menu (right-click within the navigator pane), you can conveniently access
all commands available in the pane.
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Menu Description

“New Channel” New Channel Wizard (page 61)

“New Device” New Device Wizard (page 63)

“New Tag Group” New Tag Group Wizard (page 64)

“Cut” “Edit” > “Cut”

“Copy” “Edit” > “Copy”

“Paste” “Edit” > “Paste”

“Delete” “Edit” > “Delete”

“Import” Import/Export Tag Data (page 31)
Note:
The data can only be imported into a device or tag group element.

“Export” Import/Export Tag Data (page 31)
Note:
The data can only be exported from a device or tag group element.

“Properties” Opens the wizard to update the element parameters.

Related topics

Cut (page 41)

Paste (page 42)

Paste (page 42)

Delete (page 42)

New Channel Wizard (page 61)

3.3.2 Tag Pane

The tag pane shows the tag elements  in a list structure. A wizard is started to help you
create new elements. To update existing elements, simply double-click the item to open the
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wizard. You can make direct changes to the tag elements in the list by placing the cursor in
the list cell or selecting an item from the combo box lists. To ease handling of many items,
multiple rows can be selected and changes applied to all selected elements. The list shows
all properties of the tag element in a clearly arranged manner. All commands available in this
pane are directly accessible from the toolbar or pop-up menu.

Column
number

Column
Header

Explanation

(1) Shows the status of the element:
 correct

 warning

 error
Hint: check the tool tip for help on configuring the element correctly.

(2) Name Shows the tag's name
Each tag element that is child to the same parent must have a unique
tag name, e.g. only one tag can be named "OutsideTemperature".

(3) Address Shows the element's address

(4) Data Type Shows the element's data type

(5) Creation
Time

Displays the creation time and date

(6) Access Right Shows the access rights of the tag

(7) Description Allows you to enter a description for the tag

(8) You can disable elements by deactivating this check box (multiple
selection with <Ctrl> and/or <Shift>). Disabled elements are not visible
inside the OPC client.
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Arrange elements in meaningful groups

For example, you wish to group elements by their enabled or disabled state. Simply drag the

column (8) header  inside the field "Drag a column header …" (9).

You can also sort the list of tag items by simply clicking on the column header (10).

Note

To deselect multiple selected rows, simply click into column (1), (2) or (3). Only the currently
selected row will remain selected.

For a detailed description of the tag pane, please refer to the online help under the keyword
"Tag pane".

3.3.2.1 Dummy Element of Tag Pane

In simplify creating a new element, a tag dummy element exists.

The dummy element  is only available if the list is empty.
It is used to create a new tag element by simply double-clicking the item. The wizard that
opens helps you create a new element.

3.3.2.2 Pop-Up Menu of Tag Pane

Using the pop-up menu (right-click within the tag pane), you can conveniently access all
commands available within the pane.

ACGM0143V7EN  55



3 Graphical User Interface (GUI)

Menu Description

New Tag New Tag Wizard (page 66)

Cut “Edit” > “Cut”

Copy “Edit” > “Copy”

Paste “Edit” > “Paste”

Delete “Edit” > “Delete”

Properties Opens the wizard to update the element parameters.

Related topics

Cut (page 41)

Paste (page 42)

Paste (page 42)

Delete (page 42)

New Tag Wizard (page 66)

3.3.3 System Log Pane

The system log pane displays information, warnings and error event messages.

For example, information about server start and stop events, client connects and
disconnects are data time-outs are displayed. While the server application is running,
log information is written into a log file. The log file path can be changed under “Tools” >
“Options”.

Related topics

Options (page 45)

Configure the Working Area (page 36)
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3.3.4 Server Status Pane

The server status pane shows actual status information about the server application. All
commands available in this pane are directly accessible from the toolbar or pop-up menu.

Note

The status information can also be directly retrieved from inside the OPC client by using the
System namespace.

Server Time

The server time indicates the actual date and time of the server hosting system.

Up Time

The Up Time property is available when the server is running and displays how long the
server has been up in "xxd(ays) xxh(ours) xxm(inutes) xxs(econds)".

Connected Clients

The number of connected OPC clients is displayed.

Number of Tags

"Number of Tags" shows the total number of tags created within all devices and tag groups.

Note

All tags including disabled elements are counted.

Number of Active Items

The number of tags actively monitored within any of the OPC clients (created as Items) is
displayed.
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Note

The total number of tag instances is counted; if one client monitors the same element twice
or two clients monitor the same element, the property counts both elements.

For a detailed description of the Server status pane, please refer to the online help under the
keyword "Server status pane".

3.3.4.1 Pop-Up Menu of Server Status Pane

Using the pop-up menu (right-click within the server status pane), you can conveniently
access the commands Start Server and Stop Server.

3.3.5 Help Pane

The help pane can be docked and reacts context-sensitively to the current mouse or cursor
position. You can “pin” it open or have it slide open and closed by passing the cursor over it.

See also: Help menu.

3.4 Toolbars

Each of the panes in the FP OPC Server's configuration user interface contains a toolbar
that allows you easy access to all commands available within the pane.

For a detailed description of the toolbar functions, please refer to the online help under the
keyword "Toolbars".

3.4.1 Main Toolbars

General options that are available everywhere appear in the main toolbars. You can undock
these toolbars from their original position and move them anywhere on the windows desktop.
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Symbol Description

New Project
Please refer to New Project.

Open Project
Please refer to Open Project.
See also: Project information input/output.

Save Project
Please refer to Save Project.
See also: Project information input/output.

What's This?
Please refer to What's This?.

Start
Select "Start" to start the server OPC subsystem.

Stop
Select "Stop" to stop the server OPC subsystem

3.4.2 Navigator Pane Toolbar

The navigator pane toolbar offers you easy access to the commands available in this pane.

Symbol Description

New Channel
Please refer to new channel and new channel wizard.

New Device
Please refer to new device and new device wizard.

New Tag Group
Please refer to new tag group and new tag group wizard.

Delete element
Please refer to Delete.

Element properties
Depending on the element selected the respective wizard displays the properties.

Import
Please refer to Import.

Export
Please refer to Export.

ACGM0143V7EN  59



3 Graphical User Interface (GUI)

3.4.3 Tag Pane Toolbar

The tag pane toolbar offers easy access to the pane's options.

New Tag

Click on New Tag to create a new tag element.

Delete Tag

Click on Delete to delete the currently selected single or multiple tag element(s).

Tag Properties

Click on "Properties" to display the element properties dialog filled with the tag element's
properties.

Further information:

• Tag Pane

• Wizard

3.4.4 Server Status Pane Toolbar

The server status pane's toolbar offers easy access to all commands available within the
pane.

See also:

Server Status Pane

3.5 Wizard

To simplify creating and modifying namespace elements, a wizard-like configuration dialog
has been implemented. The wizard is opened to help you create a new element when you
have double-clicked a dummy element (see also dummy element of tag pane). You can
likewise modify an existing element's properties by double-clicking on the element. The
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wizard also opens when you execute similar commands via the menu, pop-up menu or
toolbar icon.

Enter text

On the left side of the dialog text input fields, you must enter an element name, for example.
If the text you have entered is wrong, the field turns red and a tool tip assists you with an
error message.

Buttons

On the right side, the buttons, such as [OK], [Cancel] and - if available - the navigation
buttons [Next] and [Previous] can be found. By pressing [Next], the next page (also
accessible via a tab flag) is displayed.

Help

At the bottom of the dialog, the omnipresent, context-sensitive online help can be
found embedded. By selecting another control, for instance the next edit field, the help
automatically displays the corresponding help page.

3.5.1 New Channel Wizard

When you create or modify a channel element, the wizard is started in "(new) channel
mode". You can view or modify an existing element, or create a new element.

The first page identifies the channel element. The channel's name is specified here.

On the second page, you select the I/O driver. If you have selected the MEWNET driver, a
third page allows to you to edit the communication settings.

For detailed information, please refer to the online help under the keyword "New Channel
Wizard".

3.5.1.1 Channel Name

Specify a valid name for the channel element. The name has to be unique among its siblings
and may not contain white spaces or non-alphanumeric characters. The only exception is the
underscore character "_".

On the next tab, you can select the I/O driver.
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3.5.1.2 Driver Selection

Select Driver

Select the driver with which the device should be accessed. Available drivers are:

MEWNET

The MEWNET driver accesses Panasonic FP Series PLCs using the MEWTOCOL protocol.

If you have selected the MEWNET driver, a third page allows you to edit the communication
settings.

Note

The MEWTOCOL driver automatically uses the most efficient MEWTOCOL commands to
retrieve and send data to the PLC. In certain cases they can be adapted manually.

Simulation

The Simulation driver allows OPC client data to be monitored without having a PLC
connected to the PC running the FP OPC Server. Random values are set for the items the
client is monitoring.

Note

If the Simulation driver is selected, the "Communication Settings" tab is deactivated.

3.5.1.3 Communication Settings

Click on [Settings…] to open the Communication Settings Dialog.

3.5.1.4 Process all write requests

Writing data can be a very important task in your application. Depending on the
communication settings and the response time of the connected device, the OPC client
application may send write requests to the PLC faster than the data can be transferred. In
this case, only the last write request is processed and sent to the PLC.
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In certain instances, e.g. when using sliding switches in HMI applications, it may be
important for every write request to be processed and sent to the PLC. In such cases, select
the check box "Process all write requests".

Note

If more write requests are sent to the server than the server can send to the PLC, it may
negatively impact the transfer time between server and PLC.

3.5.2 New Device Wizard

When you create or modify a device element, the wizard is started in "(new) device mode".
You can view or modify an existing element, or create a new element.

The wizard shows the identification page of the device element. The device's name and
station number are specified here.

For detailed information, please refer to the online help under the keyword "New Device
Wizard".

3.5.2.1 Device Name

Specify a valid name for the device element. The name has to be unique among its siblings
and may not contain white spaces or non-alphanumeric characters. The only exception is the
underscore character "_".

3.5.2.2 Station No.

Specify the station number of the device. This number is used to distinguish between
devices if more than one device (e.g. PLC) is connected using the same communication
channel.
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3.5.2.3 Test Communication

Select [Test Communication] to test the current settings for the channel element's device
element.

3.5.3 New Tag Group Wizard

With the Tag Group Wizard, you can view or modify an existing tag group element, or create
a new element.

The wizard shows the identification page of the tag group element.

For detailed information, please refer to the online help under the keyword "New Tag Group
Wizard".

3.5.3.1 Tag group name

Specify a valid name for the tag group element. The name has to be unique among its
siblings and may not contain white spaces or non-alphanumeric characters. The only
exception is the underscore character "_".

3.5.3.2 Time stamp address for all tags in the group

Reading values, the OPC Server sends OPC Client application information on the value,
quality, and time stamp of a tag item.

The tag's time stamp will be set to the PC time when the tag value was read from the
PLC. Instead of using the PC time for the time stamp, the time stamp can be specified
by a DATE_AND_TIME variable in the PLC program. If you enter the address of a PLC's
DATE_AND_TIME variable, the OPC Server will read the time stamp value from the PLC.

The following diagram illustrates this process.
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The following picture shows the use of a time stamp in an FPWIN Pro project, FP OPC
Server and OPC client application.

Please find example projects for the FP OPC Server and FPWIN Pro in your software
installation directory.
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3.5.4 New Tag Wizard

When you create or modify a tag element, the wizard is started in "(new) tag mode". You can
view or modify an existing element, or create a new element.

The wizard shows the identification page of the tag element. The tag's name, address, data
type, access type and enabled state is set here.

For detailed information, please refer to the online help under the keyword "New Tag
Wizard".

3.5.4.1 Tag Name

Specify a valid name for the tag element. The name has to be unique among its siblings and
may not contain white spaces or non-alphanumeric characters. The only exception is the
underscore character "_".

3.5.4.2 Address

Declare the address of the tag element, such as DT0. For further information, please also
refer to data types.

3.5.4.3 Data type

Enter a valid data type corresponding to the address, e.g. "Integer" if the address is DT0. For
further information, please refer to data types.

Note

The field turns red if the data type does not match the address. The data type "Undefined" is
indicated with yellow.
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3.5.4.4 Description

Enter the description of the tag value. The description can also be seen inside the OPC client
application.

3.5.4.5 Enable Tag

Deactivate this check box to disable the tag element. In this case the element can be created
and updated within the configuration user interface, but the element is not visible from inside
the OPC client application. For further information, please refer to namespaces.

3.5.4.6 Access Right

Select the access type of the element to restrict the client access to the element. Possible
types are read only, write only and read & write.

Read only The OPC client can only read data from the item.
Note: A write request to the client leads to an access error.

Write only The OPC client application can only write data to the item.
Note: This setting leads to read errors if the client tries to retrieve data
from the item.

Read & Write With this option, data can be read from and written to the item.

3.5.4.7 Buttons of New Tag Mode

• “[Insert]”
(only available if new tag element is created)
Adds the currently specified element to the tag list and the name is updated to
<Name>_xx, where xx is an incremented digit (e.g. Tag ® Tag_0). The address is
likewise incremented (e.g. DT0 ® DT1).

• “[Remove]”
(only available if new tag element is created)
Removes the element last entered.

Note

“[Insert]” and “[Remove]” are only available if the dialog has been opened to create new tag
elements.
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3.6 Project Information Input/Output

3.6.1 Load/Save The Project

To save a new project or change an existing project, data can be stored in a project file on
the hard disk in *.pos or *.xml format.

For further information on loading and saving project data, please refer to Open/Save
Project.

3.6.2 Import/Export Tag Information

Tag group and tag elements can be exported to an XML (*.xml) or CSV (*.CSV) file. The
CSV file is compatible with the GVL CSV export file of FPWIN Pro. Project data (tags) can
also be exchanged with other OPC server providers. For further information, please refer to:
Import/Export Tag data.

3.7 “Communication settings” dialog

Use this to set communication parameters if you are using the MEWNET driver or if you
want to configure the MEWTOCOL OPC server compatibility namespaceMEWTOCOL OPC
Server compatibility namespace.

The following network types are provided:

• Serial

• Modem

• Ethernet

• USB

All communication settings are made in the “Communication settings”, which can be opened
in two ways:

• Via the channel properties. In this case the settings are stored in the channel properties in
the project file.

• Via “Server” > “Communication Settings (MEWTOCOL OPC Server compatibility
namespace)”. In this case the settings are stored in the folder C:\Users\UserName
\AppData\Roaming\Panasonic-ID SUNX Control\PxMEWNET. The user name in the
folder is the Windows login name of the current user.
The file names for the different network types are as follows:
‒ The serial communication settings are stored in the file "PxMEWCOMM.INI".
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‒ The Ethernet communication settings are stored in the file “PxMewMultiEther.dat”.

• From version 2.100, communication is done via the PxMewnet manager. In former
versions (lower than 2.100) the communication is done via the NAiS MEWNET manager,
which stores the communication settings in different files. To keep the settings, please
refer to the corresponding troubleshooting section.

Related topics

3.7.1 Serial Communication Settings

If you select “C-Net (RS232, UBS)” as the network type, the following options are available:

Parameter Description

“Port number” Select the port number.

“Baud rate” Depending on the PLC, select a baud rate between 1200 and 115200bit/
s for communication between PLC and PC. The default setting is
9600bit/s.

“Data length” Select either 7 or 8bits (default setting: 8 bit).

“Stop bits” Select either 1 or 2 bits (default setting: 1 bit).

“Parity” Select the parity setting (default setting: odd).

“Timeout” Set a timeout from 0 to 60s to connect to the PLC (default setting: 5s).

“Automatic
communication setting”

The software will automatically find matching communication settings
(default: all check boxes are activated).
Warning: Disabled parameters will be excluded from automatic
configuration.

Note

The FP OPC Server automatically searches for the suitable parameters unless you have
deactivated this feature.

3.7.2 Ethernet communication settings

The Ethernet communication settings can only be accessed via the channel properties. Set
the communication parameters according to your hardware. This connection is based on
TCP/IP protocol.

Set or change the following parameters if necessary:
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Parameter Description

“Title” Enter a title up to 38 characters long.

“Use ET-LAN unit” Activate the checkbox when you use the ET-LAN unit.
Do not activate the checkbox when using the Ethernet-RS232C
converter, etc., for example.

“Automatically acquire IP
address”

Set automatically. If not displayed, set properties of TCP/IP from network
setting in control panel. (The setting procedure differs depending on
the operating system used. Please refer to the manuals and help of the
operating system.)

“Port number” Specify a value between 1025 and 32767 in decimal format (default:
1025). The Port No. for the IP address must be a unique, i.e. it cannot be
used twice on your computer.

“Station No.” Specify a value between 1 and 64 in decimal format (default: 64).
Specify a Station No. different from the destination Station No. (PLC)
that follows.
(If no ET-LAN unit is used, the setting under “Station No.” is ignored.)

“IP address” Specify the IP address of destination (PLC) to communicate with.

“Port number” Specify a value between 1 and 32767 in decimal format (default: 1025)
different from above.

“Station No.” Specify a value between 1 and 64 in decimal format (default: 1). Specify
a Station No. different from the computer’s Station No. above.
(If no ET-LAN unit is used, the setting under “Station No.” is ignored.)

“Communication timeout” Specify a value between 1 and 950 seconds (default: 10).

“Connection timeout” Specify a value between 1 and 180 seconds (default: 60).

The following command buttons are available:

“OK” Use this command button to save the communication settings. However, the
current settings are not entered in the list of registrations. If you want to enter
them to the list, use “Add registration” before selecting “OK”.

“Initialize” Use this command button to reset the current parametersettings to the default
values.

“Browse” Use this command button when another program (a PEW application) is
communicating with the PLC via Ethernet and you want to connect to the same
PLC. Then you can connect to the PLC easily by selecting the task in the TCP/IP
Run List. Refer to the other task’s settings for details.

“List
registrations...”

Use this command button to reuse already registered parameters.

“Add registration” Use this command button to add the current setting parameters to the list of
parameters.
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3.7.3 Ethernet (local) communication settings

The dialog is only available via “Server” > “Communication Settings” when you have set
the parameter “Enable MEWTOCOL OPC Server comatibility namespace” to TRUE under
“Tools” > “Options” in the “Client Interaction Settings” pane.

Note

You can only change the communication parameters for the OPC Server if the OPC
subsystem has not been started.

Set the communication parameters according to your hardware. This connection is based on
TCP/IP protocol.

Read the "ET-LAN SYSTEM Technical Manual" when you are using the ET-LAN unit.

If you select “Ethernet (local)” as the network type, the following options are available. Note
that the bottom half of the dialog looks different depending on whether you have activated
the option “Use link station No.” or not.

Parameter Description

“Automatically
acquire IP
address”

Activated by default. If not displayed, set properties of TCP/IP
from network setting in control panel. (The setting procedure
differs depending on the operating system used. Please refer
to the manuals and help of the operating system.)

“IP address” Specify the IP address of destination (PLC) to communicate
with if the option “Automatically acquire IP address” is
deactivated.

“Port number” Specify a value between 1025 and 32767 in decimal format
(default: 1025). The port number for the IP address must be a
unique, i.e. it cannot be used twice on your computer.

“Computer”

“Station No.” Specify a value between 1 and 64 in decimal format (default:
64). The station number must be different from the destination
station number (PLC) that follows.
(If no ET-LAN unit is used, the setting under “Station No.” is
ignored.)

“Communication timeout” Specify a value between 1 and 950 seconds (default: 15).

“Connection timeout” Specify a value between 1 and 180 seconds (default: 60).

• If “Use link station No.” is deactivated (default setting), use the command buttons “Add”
or “Change” to open the dialog “Register destination”. Here you can add new or change
existing destinations.
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Parameter Description

“Use ET-LAN unit” Activate the option when you are using the ET-LAN unit.
Do not activate the option when using the Ethernet-
RS232C converter, etc., for example.

“Station No.” Specify a value between 1 and 64 in decimal format
(default: 1). The destination station number must
be different from the station number entered under
“Computer”.
(If no ET-LAN unit is used, the setting under “Station No.” is
ignored.)

“IP address” Specify the IP address of the destination (PLC) to
communicate with.

“Port number” Specify a value between 1 and 32767 in decimal format
(default: 1025) that is different from the port number shown
next to “Computer port no.”.

“Computer port no.” Read-only field displaying the port number you have
entered in the previous dialog for information.

• When the option “Use link station No.” is activated, only one destination can be entered.

Parameter Description

“Use ET-LAN
unit”

Activate the option when you are using the ET-LAN unit.
Do not activate the option when using the Ethernet-
RS232C converter, etc., for example.

“IP address” Specify the IP address of the destination (PLC) to
communicate with.

“Port number” Specify a value between 1 and 32767 in decimal format
(default: 1025) that is different from the port number
entered under “Computer”.

“Destination”

“Station No.” Specify a value between 1 and 64 in decimal format
(default: 1). The destination station number must
be different from the station number entered under
“Computer”.
(If no ET-LAN unit is used, the setting under “Station No.” is
ignored.)

The following command buttons are available:

“OK” Use this command button to save the communication settings. However, the
current settings are not entered in the list of registrations. If you want to enter
them to the list, use “Add registration” before selecting “OK”.

“Initialize” Use this command button to reset the current parametersettings to the default
values.
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Related topics

MEWTOCOL OPC server compatibility namespace (page 76)

Start/Stop the FP OPC Server application (page 19)

3.7.4 USB (GT) communication settings

If you select “USB (GT)” as the network type, you can configure transparent PLC
communication via the USB port of a GT panel.

Specify a timeout value between 1s and 60s (default setting: 15s).

3.8 System tray

When the server application is started, a tray icon appears in the window's system tray.
The icon offers easy access to the main server functions, such as starting and stopping the
server and maximizing or exiting the application.

In case of an automatic start, i.e. the OPC client starts the FP OPC Server, the OPC Server
is minimized to the tray only. To maximize the FP OPC Server configuration user interface,
either double-click the tray icon or select “Minimize/Maximize to/from Tray” from the System
Tray menu.
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4 Namespaces

4.1 Introduction to namespaces

A namespace is a hierarchical tree structure of elements. Namespaces are set up within the
server and can be browsed for with an OPC client application.

Three different namespaces can be built within the server:

1. User-defined manual namespace

2. System status namespace

3. MEWTOCOL OPC Server compatibility namespace that ensures backward compatibility
with the previous MEWTOCOL OPC Server.

4.2 Static, Manually Defined Namespace

The static namespace has to be defined by the user in the FP OPC Server configuration user
interface as described in the previous chapters (left hand image).
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The root elements in the tree are the channel elements, which embody the means of
communication, i.e. the communication line.

Server side Client side

Each channel element can contain device elements, which represent the devices where
the data sources are located. On the next level, tag groups combine elements in a way that
makes sense for the particular application. The leafs of the tree are the tag elements. These
elements directly represent the data sources offered to the OPC client application.

On the right, the namespace representation within the OPC client can be seen.

Note

You cannot use elements named COMXXNXX or ETHERNXXNXX (e.g. COM1N64)
in accordance with the regulations of MEWTOCOL OPC server compatibility
namespaceMEWTOCOL OPC Server compatibility namespace.

4.3 System Status Namespace

The system status namespace provides the client application with general feedback about
the server.

For a detailed description of the read only tags, please refer to the online help under the
keyword "System Status Namespace".

Note

The following tags are read only.
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_SystemDate

Indicates the current date of the system on which the server is running. The format of this
string is defined by the operating system date/time settings.

_SystemTime

Indicates the current time of the system on which the server is running. The format of this
string is defined by the operating system date/time settings

_SystemDateTime

Indicates the GMT date and time of the system on which the server is running. The format of
the string is “2006-07-26 07:50:30”

_Uptime

Indicates the time span between the current time and when the server was started. It shows
how long the server has been running. The format of the string is “… 1d 13h 27m 55s”, for
instance.

_ProjectPath

Indicates the full path and file name of the currently loaded project.

_TotalTagCount

Indicates the total number tags defined in the static namespace.

_ClientCount

Indicates the total number of connected OPC client applications.

_ActiveTagCount

Indicates the number of item instances in all OPC client applications of static Tags.

4.4 MEWTOCOL OPC server compatibility namespace

The previous OPC server, the MEWTOCOL OPC Server, did not support the definition of a
static namespace. The tags are accessed by defining the access path according to a certain
syntax.

In order to be backward compatible, the FP OPC Server supports the MEWTOCOL
OPC Server namespace. You must define the communication settings beforehand in the
communication settings dialog that opens via “Server” > “Communication Settings”.
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Note

• In this case the settings are stored in the files "PxMEWCOMM.INI" and
"PxMewMultiEther.dat" in the folder C:\Users\UserName\AppData\Roaming
\Panasonic-ID SUNX Control\PxMEWNET. The user name in the folder is the
Windows login name of the current user.

• From version 2.100, communication is done via the PxMewnet manager. In former
versions (lower than 2.100) the communication is done via the NAiS MEWNET manager,
which stores the communication settings in different files. To keep the settings, please
refer to the corresponding troubleshooting section.

You must specify the communication channel on the first layer:

COM (serial and modem) communication

XX The first two placeholders should specify the communication port to be used.

N Optional. For C-NET must be "N".

XX Optional. The second two placeholders specify the PLC station number if the PLC is
connected via C-NET.

Ethernet communication
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Note

For further information, please refer to Panasonic FP PLC Network Types.

The second layer represents the Tag layer directly. Here, the item corresponding to the data
source is created according to the following syntax conventions:

<[1][2][3][4]Address where:

Optional Description Values Notes

[1] Specifies a memory bank
number

b0to b15 If empty, no bank is
specified.

[2] • Specifies the number of
numerical data words.

w1 (1 word)
w2 (double
word)

If empty, 1-word data types
are used.

• Specifies the number of
character data words.

s1 to s256

[3] Specifies the Item as a real or
BCD value.

Real: f
BCD: B

If empty, the value is
displayed as decimal

[4] Specifies double word. D If empty, 1-word data types
are used.
D overrides w1 specified in
[2]

Note

• In contrast to the MEWTOCOL OPC Server, modem connections can also be used via
COMXXNXX nodes.

• This namespace can also be used to dynamically create item instances within the OPC
client application.
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5 Appendix

5.1 Panasonic Addresses

Panasonic FP Series PLCs use addresses from which you can read data or to which you
can write data. Both bit and word addresses are used.

• Bit addresses
If, for example, you wish to provide the address of the first unit’s (an input unit) first input
and the second unit’s (an output unit) fourth output, the FP address for an FP1 is X0 (1st
input) and Y3 (4th output).
For internal memory areas, supply the reference letter and the number of the memory
area as the FP address, e.g. R9000 for the 9000 link or DT9001 for the 9001 data
register. The addresses for the memory areas are contained in your hardware description.

• Word addresses
Individual bit addresses for inputs (X), outputs (Y) and flags (R) can also be saved in
words. 16 bits form a word. A word address containing 16 flags looks like this:

The bits are numbered hexadecimally from right to left. How the individual bits are
assigned can be seen from the 3 flag words WR0 to WR2:
R5 is the 6th bit in word WR0
R1A is the 11th bit in word WR1
R2E is the 15th bit in word WR2
When the status of a bit changes, the value of the whole word changes.

5.1.1 FP addresses

Example

WX4, S23:UM4A, Y3E, S12, R100A, E1234, DT1234

Format:

• Slot address prefix for unit memory addresses, e.g. S23:UM4A (FP7 only)
‒ Slot address specifier S

‒ Slot number “dd”, e.g. 23 of S23:UM1A0
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‒ Separator ':'

• Double size prefix D only for 32-bit values of words

• FP address prefix:
‒ For 1-bit values, e.g. X, Y, R

‒ For 16-bit words with bits, e.g. WX, WY, WR

‒ For 16-bit words without bits, e.g. DT, FL

• Address offset:
‒ For bits in word data "dddX", e.g. 100A of R100A

‒ For bits not in word data "dddd", e.g. 1234 of E1234

‒ For word data "dddd", e.g. 1234 of DT1234

‒ For word data in the unit memory "XXXX", e.g. ABCD of S3:UMABCD

Note

dd, placeholder for decimal numbers

XX, placeholder for hexadecimal numbers

Index modifiers cannot be used.

5.1.2 Memory areas

The default initial values are 0 or FALSE.

Availability of memory areas:

The FP series PLCs have many different memory areas, which support 1-bit, 16-bit, or 32-
bit addressing. Availability of the memory areas varies, depending on the PLC's processor.
Addresses may be specified in FP format (e.g. X) or IEC format (%IX).

Memory area 1-bit 16-bit 32-bit 16-bit PLCs 32-bit PLCs

Input X WX DXW ● ●

Output Y WY DYW ● ●

Internal relay R WR DWR ● ●

Timer relay T ● ●1)

SV ●Timer set value register

TSV ●1)

EV ●Timer elapsed value
register

TEV ●1)

Counter relay C ● ●1)
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Memory area 1-bit 16-bit 32-bit 16-bit PLCs 32-bit PLCs

SV ●Counter set value register

CSV ●1)

EV ●Counter elapsed value
register

CEV ●1)

Data register DT DDT ● ●

File register FL DFL ● ●

Link relay L WL DWL ● ●

LD ●Link register

DLD ●

System relay SR WSR DWS ●

SD ●System data

DSD

Unit memory Sx:UM Sx:DUM ●

IX ●Index register

DIX ●

Error alarm relay E ● ●

Pulse relay P ●

1) On the FP7, these addresses are reserved for the system.

5.2 Panasonic Data Types

Panasonic's FP OPC Server supports several data types described hereafter.

5.2.1 Undefined - Undefined Data Type

An undefined data type is selected per default. If this data type is not changed, the OPC
Server automatically adopts the data type according to the address of the variable.

5.2.2 Boolean - Boolean Data Type (1-bit)

Variables of the data type BOOL are binary variables. They can either have the value 0 or 1,
and are 1 bit long.
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Condition Meaning Explanation

0 FALSE The variable is switched off, i.e. it is not set.

1 TRUE The variable is switched on, i.e. it is set.

5.2.3 Signed 16-bit

Variable values of the data type Signed 16-bit are natural numbers without decimal places.

Range: -32768–32767

5.2.4 Unsigned 16-bit

Variable values of the data type Unsigned 16-bit are numerical numbers without decimal
places.

Range: 0–65535

5.2.5 Signed 32-bit

Variable values of the data type Signed 32-bit are natural numbers without decimal places.

Range: -2147483648–2147483647

5.2.6 Unsigned 32-bit

Variable values of the data type Unsigned 32-bit are numerical numbers without decimal
places.

Range: 0–4294967295

5.2.7 Word 16-bit

A variable of the data type Word 16-bit consists of 16 binary states. The switching states of
16 in/outputs can be combined in one word.
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5.2.8 Word 32-bit

A variable of the data type Word 32-bit consists of 32 binary states. The switching states of
32 in/outputs can be combined in one double Word.

5.2.9 Float 32-bit

Variables of the data type Float 32-bit consist of real numbers or floating point constants and
can include up to seven effective digits. The mantissa consists of 23 bits and the exponent of
8 bits (based on IEEE754).

31 30 29 23 22 16... ... 14 13 12 3 2 1 015 ...(1)

(3) (4)(2)

(1) Bit position
(2) Sign bit: 0 positive, 1 negative
(3) Exponents (8-bit)
(4) Mantissa (23-bit)

-3.402823466*E38 to -1.175494351*E-38

0.0

Range:

+1.175494351*E-38 to +3.402823466*E38

5.2.10 String - String Data Type (Variable Length)

The data type STRING consists of a series of up to 255 ASCII characters. All ASCII
characters are considered as characters.

5.2.11 BCD 16-bit

The BCD represents a code scheme for numbers that allows base-ten computer calculation
instead of the more common base two. BCD manipulation preserves accuracy by reducing
round-off errors. BCD encoding is performed by using a four-digit binary number to encode
each digit of the base ten number.

BCD Decimal

0000 0

0001 1
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BCD Decimal

0010 2

0011 3

0100 4

0101 5

0110 6

0111 7

1000 8

1001 9

5.2.12 BCD 32-bit

The encoding of the BCD 32-bit is similar to the BCD 16-bit data type, but instead of being
16 bits long, the BCD 32-bit consists of 32 bits.

5.2.13 Date

Variable values of the data type Date are date literals.

Range: 2001-01-01–2099-12-31

5.2.14 Date And Time

Variable values of the data type Date And Time are date and time literals.

Range: 2001-01-01-00:00:00– 2099-12-31-23:59:59

5.2.15 Time Of Day

Variable values of the data type Time Of Day are time of day literals.

Range: 00:00:00–23:59:59
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5.3 Panasonic FP PLC Network Types

A Panasonic FP Series PLC can be connected to the PC in various ways. The PLC can be
connected using the serial port or Ethernet.

Tip

For further information on the different network types and how to connect and to wire the
PLC, please refer to the appropriate hardware manual.

5.3.1 Serial Network

Direct connection

The PLC is directly connected to the PC using the serial communication line.

C-NET adapter connection

A maximum of 99 PLCs (FP-Sigma PLCs) can be connected to a single PC.

The access path is for example (using the MEWNET compatibility syntax):
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• Node1: COM1N1

• Node2: COM1N2

• Node3: COM1N3

Note

This version of the FP OPC Server does not support the MEWNET W/W2 remote access.

5.3.2 Ethernet Network

PLCs can be connected to the PC via Ethernet.

Each PLC is connected to a hub or switch.

The access path is for example (using the MEWNET compatibility syntax):

• Node1: ETHERN1

• Node2: ETHERN2

• Node3: ETHERN3

Note

This version of the FP OPC Server does not support the MEWNET W/W2 remote access.
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5.4 DCOM configuration

Step 4: Activate the interactive user

1. Under “My Computer”, expand “DCOM Config”

2. Select “FP OPC Server 2”

3. From the pop-up menu, open the FP OPC Server properties

4. Select the “Identity” tab and activate “The interactive user” who shall run the OPC
Server
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5. “OK”
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Step 5: Reboot your PC after changing the DCOM security settings

5.5 Troubleshooting, warnings and error dialogs

How to keep the communication settings for the MEWTOCOL OPC Server compatibility

namespace

Note

The Ethernet and serial communication settings for the MEWTOCOL OPC Server
compatibility namespace are stored by the corresponding MEWNET manager.

Because from this version the PxMEWNET manager is used instead of the NAiS MEWNET
manager you have to execute the following steps to keep the communication settings:

1. Close the FP OPC Server

2. Copy the files “NAIS_MewMultiEther.dat” and “NAIS_MEWCOMM.INI” from folderC:
\Users\UserName\AppData\Roaming\Panasonic MEW Control\MEWNET

Manager into folder C:\Users\UserName\AppData\Roaming\Panasonic-ID
SUNX Control\PxMEWNET

Replace <UserName> in the folder name with your Windows login name.

3. Rename “NAIS_MewMultiEther.dat” to “PxMewMultiEther.dat”

4. Rename “NAIS_MEWCOMM.INI” to “PxMEWCOMM.INI”

5.6 List of abbreviations

The following abbreviatinos are used throughout this documentation:

Abbreviation Explanation

BCD Binary Coded Decimal

COM Component Object Model

CSV Character Separated Values

DA Data Access

DCOM Distributed Component Object Model

DDE Dynamic Data Exchange

GVL Global Variable List (Control FPWIN Pro)

OLE Object Linking and Embedding

OPC OLE for Process Control
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Abbreviation Explanation

OutProc An OutProc server realizes one of three characteristics of a standardized OPC
server. If implemented as an OutProc server, the application is started by an
OPC client from an autarkic executable file. The server application can reside on
the local or a remote machine.

PLC Programmable Logic Controller

XML Extended Markup Language

90 ACGM0143V7EN



 6 Record of Changes

6 Record of Changes

Manual No. Date Description of Changes

ACGM0143V1.0END Dez. 2006 First edition

ACGM0143V1.1END Jan. 2007 Updated documentation: notes on removing the
software.

ACGM0143V1.2END Apr. 2007 The description of Ethernet (Local) communication has
been moved to the section Communication Settings.

ACGM0143V1.3END Mai 2007 Microsoft Windows® Vista compatible

ACGM0143V1.4EN Sept. 2007 MEWNET W/W2 connection removed

ACGM0143V1.5EN Mai. 2008 New options are available under “Tools” > “Options” >
“Event Log Settings”:
• Enable debug message logging
• Enable memory status message logging

Jan. 2010 Update for release of FP OPC Server 2.0.2.0. See the
section "New in this version" in the online help.

Sept. 2010 Update for release of FP OPC Server 2.0.2.1. See the
section "New in this version" in the online help.

ACGM0143V2EN Oct. 2011 Update for release of FP OPC Server 2.1.0.0. See the
section "New in this version" in the online help.

ACGM0143V3EN July 2013 Update for release of FP OPC Server 2.1.0.1. See the
section "New in this version" in the online help.

ACGM0143V4EN March 2020 Update for release of FP OPC Server 2.1.1.0. See the
section "New in this version" in the online help.

ACGM0143V5EN Nov. 2020 Update for release of FP OPC Server 2.1.2.0. See the
section "New in this version" in the online help.

ACGM0143V6EN Apr. 2021 Update for release of FP OPC Server 2.1.3.0. See the
section "New in this version" in the online help.

ACGM0143V7EN July 2022 Update for release of FP OPC Server 2.1.4.0. See the
section "New in this version" in the online help.
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